npm 命令报错Could not retrieve https://npm.taobao.org/mirror
web nodejs 2024-05-26 157 0
关于本站

“最难不过坚持”

本人承接扒站仿站,php网站维护,病毒查杀,网站编辑,网站改版,html制作

有需要网站维护,改版,病毒查杀,网站编辑,网站备案,html制作等相关的工作可以联系我。
本人有多年相关工作经验,也可提供免费咨询,交个朋友。
有需要探讨问题的朋友,也可以加我微信,共同探讨!
微信:15011482830 QQ:408917339

6764623 2630 39
最新评论
https://jueru.net/
评 留言
:weixiao:
评 留言
:shuijiao: :weiqu: :zhenbang: :leng:
评 留言
:yiwen: :yiwen: :yiwen: :yiwen:
评 EasySass: could not generate CSS file. See Output panel for details.
这个业务逻辑多少都有点奇怪了,阅读浏览次数增值在新闻详情页的控制器方法里setInc,这怎么还写进模型事件里了。如果非要用onAfterRead也可以,把新闻文章的内容单独分出来一个news_content表,然后把它和news做关联,然后给news_content表的onAfterRead事件做增值处理,这样点进新闻页内查询到文章内容时才会触发它。
评 TP6模型事件-查询后onAfterRead不好用
文章标签更多
ThinkPHP (254)
Mysql (58)
DedeCms (33)
jQuery (67)
证件照 (1)
setInc (4)
setDec (4)
onclick (5)
打开边栏(ESC) 关闭边栏(ESC)

npm 命令报错Could not retrieve https://npm.taobao.org/mirror

今天想用nvm切换node的版本的时候,发生了以下的错误

C:\Windows\system32>nvm list available
 
Could not retrieve https://npm.taobao.org/mirrors/node/index.json.
 
Get "https://npm.taobao.org/mirrors/node/index.json": x509: certificate has expired or is not yet valid:
from clipboard

原因是淘宝的镜像源改名了

淘宝原镜像域名(registry.npm.taobao.org)的 HTTPS 证书已于 2024年1月22号 正式到期,如果需要继续使用淘宝镜像,需要将域名修改为最新的域名(registry.npmmirror.com)。
因此使用nvm的时候会报上面的错误,因此呢我们需要找到nvm的下载目录,

可以使用这个命令得到nvm安装路径
nvm root

里面有个setting.txt的文件,以前使用的镜像是这个

node_mirror: https://npm.taobao.org/mirrors/node/
npm_mirror: https://npm.taobao.org/mirrors/npm/
现在改成这个

node_mirror: http://npmmirror.com/mirrors/node/
npm_mirror: http://registry.npmmirror.com/mirrors/npm/

也可以用命令的方式,更改淘宝镜像源

//命令行
nvm npm_mirror https://npmmirror.com/mirrors/npm/
nvm node_mirror https://npmmirror.com/mirrors/node/
现在可以重新使用nvm了。

版权声明:本篇文章来源于网络。 来源链接

相关推荐
windows如何把已安装的nodejs高版本降级为低版本
nodejs | 2022-10-17 2265
第一步:先清空本地安装的node.js版本 1.按健win+R弹出窗口,键盘输入cmd,然后敲回车,然后进入命令控制行窗口,并输入where node查看之前本地安装的node的路径 2.找到上面找到的路径,将node.exe所在的父目录里面的所有东西都删除 3.为了彻底删除之前安装的node.js,鼠...
This application is only supported on Windows 8.1, Windows Server 2012 R2, or hi gher.
nodejs | 2022-07-06 1962
有的nodejs版本不支持win7,在win7系统中执行npm -v时会有以下提示 This application is only supported on Windows 8.1, Windows Server 2012 R2, or hi gher. 下载v12.16.2及之前的版本即可 https://nodejs.org/d...
评论:0条
评论加载中...
发表评论